Punch Clock degraded performance
Incident Report for Planday
Resolved
This incident has been resolved.
Posted Jul 09, 2018 - 17:14 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 09, 2018 - 16:08 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 09, 2018 - 15:18 CEST
Investigating
Some users might be experiencing degraded performance on Punch Clock.
We are currently investigating the issue and an update will follow soon.

We apologise for the inconvenience.
Posted Jul 09, 2018 - 15:08 CEST
This incident affected: Punch Clock.