Some customers unable to use Punch Clock
Incident Report for Planday
Resolved
The fix we rolled out successfully resolved the issue that was preventing some users from being able to access Punch Clock. Thank you for your patience while our team worked this out. We're sorry for any hold up this may have caused you.
Posted about 2 months ago. Apr 28, 2019 - 18:18 CEST
Monitoring
We have implemented a fix for the issue causing some customers to have difficulty accessing Punch Clock. We are monitor the results closely. Thank you for your patience.
Posted about 2 months ago. Apr 28, 2019 - 17:12 CEST
Investigating
We are currently investigating this issue.
Posted about 2 months ago. Apr 28, 2019 - 15:16 CEST
This incident affected: Punch Clock.