Response times
Incident Report for Planday
Resolved
We’re relieved to say we’re out of the woods!
Thanks for bearing with us while we fixed this.
Posted Dec 14, 2018 - 14:35 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 14, 2018 - 13:23 CET
Update
We are continuing to investigate this issue.
Posted Dec 14, 2018 - 13:11 CET
Investigating
Some users might experience longer response times on Punch Clock and Mobile App.
We are currently investigating the issue.
Posted Dec 14, 2018 - 13:02 CET
This incident affected: Web, Punch Clock, and Mobile App - iOS.