Degraded performance for all accounts
Incident Report for Planday
Resolved
Planday accounts are up and running now. Thanks for bearing with us while we investigating this
Posted 7 months ago. Jan 28, 2019 - 16:34 CET
Investigating
We’re very sorry to say that a large number of Planday accounts are experiencing degraded performance at the moment. Especially payroll operations will take longer than normal. We greatly appreciate your patience.
Posted 7 months ago. Jan 28, 2019 - 12:31 CET
This incident affected: Planday Web, Punch Clock, API and Mobile App (Mobile App - iOS, Mobile App - Android, Kiosk App).