we have queuing on Web Portal
Incident Report for Planday
Resolved
This incident has been resolved.
Posted about 1 month ago. Sep 12, 2019 - 13:23 CEST
Investigating
We are currently investigating this issue.
Posted about 1 month ago. Sep 12, 2019 - 13:09 CEST
This incident affected: Mobile App (Mobile App - iOS, Mobile App - Android, Kiosk App) and Planday Web, Punch Clock, Help Chat, API.