Some customers have issues with Punch Clock
Incident Report for Planday
Resolved
This incident has been resolved.
Posted 17 days ago. Oct 04, 2019 - 10:56 CEST
Update
We are continuing to monitor for any further issues.
Posted 17 days ago. Oct 04, 2019 - 10:56 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 17 days ago. Oct 04, 2019 - 10:55 CEST
Update
We are continuing to investigate this issue.
Posted 17 days ago. Oct 04, 2019 - 10:43 CEST
Investigating
We are currently investigating this issue.
Posted 17 days ago. Oct 04, 2019 - 10:24 CEST
This incident affected: Planday Web.