SMS currently delayed
Incident Report for Planday
Resolved
This incident has been resolved.
Posted Apr 02, 2020 - 08:48 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 02, 2020 - 08:46 CEST
Investigating
Text messages are currently delayed for our users- our team is investigating the issue and we will update you within the next hour or as events warrant.
Posted Apr 02, 2020 - 08:34 CEST