Long response times for all accounts
Incident Report for Planday
Resolved
We’re happy to say we’re out of the woods! Planday accounts are now back up and running. Thanks for your patience with us while we got it fixed.
Posted Oct 17, 2019 - 16:30 CEST
Investigating
We’re very sorry to report that a large number of Planday accounts are experiencing very long response times right now. Fixing this is our top priority. We really appreciate your patience with us. The next update will be in 15 minutes.
Posted Oct 17, 2019 - 16:14 CEST
This incident affected: Mobile App (Mobile App - iOS, Mobile App - Android, Kiosk App) and Planday Web, Punch Clock, API.