Punch Clock and App Incident
Incident Report for Planday
Resolved
After monitoring both Punch Clock and Mobile App carefully, we can conclude that we have normal response times and so we have closed this incident. We want to thank all customers for your patience as we worked on a solution.
Posted Jan 15, 2018 - 18:51 CET
Update
We applied a change to our infrastructure on Saturday in order to improve response times on both Punch Clock and Mobile App. We will continue to monitor the situation for the rest of the day, before closing the incident.

Thank you for your patience.
Posted Jan 15, 2018 - 13:30 CET
Monitoring
While we are working on permanent fix, we have applied a temporary solution. We are monitoring the situation, but some clients might experience slowdowns during the weekend. An update will follow on Monday.
Posted Jan 12, 2018 - 14:12 CET
Identified
We have identified the problem on PunchClock and Mobile App.
While we are working on a solution, some clients might experience slowdowns.

An update will follow tomorrow, Friday.
Posted Jan 11, 2018 - 15:49 CET
Investigating
We are currently experiencing issues on Punch Clock and App, affecting all customers. We will send an update as soon as we have identified and solved the incident.
Posted Jan 11, 2018 - 15:17 CET