Degraded performance affecting some accounts
Incident Report for Planday
Resolved
This incident has been resolved.
Posted Apr 19, 2018 - 17:04 CEST
Monitoring
Our performance is back to normal, but we will continue to monitor the situation.
We apologise for the inconvenience.
Posted Apr 19, 2018 - 15:25 CEST
Investigating
We’re sorry to say that currently seeing degraded performance for some Planday accounts right now. We appreciate your patience while we look into this!
Posted Apr 19, 2018 - 14:31 CEST