Degraded performance for some accounts
Incident Report for Planday
Resolved
After monitoring our systems closely, we now consider this incident as resolved.

Thank you for hanging in there.
Posted May 29, 2019 - 15:14 CEST
Monitoring
Due to unusually high usage of some parts of our platform, users may experience slow performance. We are monitoring the situation carefully to manage the impact. We are sorry for any inconvenience this may cause you.
Posted May 29, 2019 - 11:06 CEST
Update
We are continuing to investigate this issue.
Posted May 29, 2019 - 10:58 CEST
Investigating
We’re very sorry to say that some Planday accounts are experiencing degraded performance at the moment. Fixing this is our #1 priority right now. We greatly appreciate your patience.
Posted May 29, 2019 - 10:31 CEST
This incident affected: Mobile App (Mobile App - iOS, Mobile App - Android, Kiosk App) and Planday Web, Punch Clock, Help Chat, API.