Log in issues on Web Punch Clock
Incident Report for Planday
Resolved
This incident has been resolved.
Posted Mar 01, 2021 - 12:03 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 01, 2021 - 11:54 CET
Investigating
We’re sorry to report that some users are currently unable to log into Planday Web Punch Clock.

Our team is working to identify the root cause and implement a solution.

We will send an additional update in 20 minutes or as events warrant.
Posted Mar 01, 2021 - 11:51 CET
This incident affected: Punch Clock.