Degraded performance for some Planday accounts
Incident Report for Planday
Resolved
This incident has been resolved.
Posted Mar 02, 2021 - 16:16 CET
Monitoring
Impact has been mitigated for the subset of customers affected by this issue.
Posted Mar 02, 2021 - 12:46 CET
Update
We are continuing to investigate this issue.
Posted Mar 02, 2021 - 10:13 CET
Investigating
Some Planday accounts are experiencing degraded performance.
Our team is working to identify the root cause and implement a solution.
We will send an additional update in 30 minutes or as events warrant.
Posted Mar 02, 2021 - 09:36 CET
This incident affected: Web.