Punch Clock and App Incident
Incident Report for Planday
Postmortem

Description:

This Incident was caused by increased traffic during peak hours, affecting both the Punch Clock and Mobile Application performance.

Solution:

A dedicated team is working hard towards delivering a new service that will make it easier for the Punch Clock and Mobile application to handle more traffic during peak hours.

Posted Apr 06, 2018 - 15:21 CEST

Resolved
This incident has been resolved.
Posted Mar 21, 2018 - 17:04 CET
Monitoring
We’re relieved to say we’re out of the woods! Punch Clock and App are both up and running now.
Thanks for bearing with us while we fixed this.
Posted Mar 21, 2018 - 16:40 CET
Investigating
There is currently an issue with accounts using Punch Clock and Mobile App. We’re doing everything we can to resolve this immediately.
Posted Mar 21, 2018 - 16:16 CET