Degraded performance for all accounts
Incident Report for Planday
Resolved
This incident has been resolved.
Posted Feb 13, 2019 - 14:44 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 13, 2019 - 14:33 CET
Investigating
We’re very sorry to say that a large number of Planday accounts are experiencing degraded performance at the moment. Fixing this is our #1 priority right now. We greatly appreciate your patience.
Posted Feb 13, 2019 - 14:31 CET
This incident affected: Web, Mobile App - iOS, Mobile App - Android, and Mobile Kiosk App.