Some users cannot access Punch Clock on web
Incident Report for Planday
Resolved
This incident has been resolved.
Thank you for bearing with us.
Posted 4 months ago. Apr 11, 2019 - 20:01 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 4 months ago. Apr 11, 2019 - 19:56 CEST
Identified
Some users cannot access Punch Clock on web.
The issue has been identified and a fix is being implemented.
Posted 4 months ago. Apr 11, 2019 - 19:41 CEST
This incident affected: Punch Clock.