Problems loading some accounts
Incident Report for Planday
Resolved
This incident has been resolved.
Posted Jun 16, 2020 - 22:00 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 16, 2020 - 17:17 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 16, 2020 - 16:52 CEST
Update
We are continuing to investigate this issue.

Next update is at 17:00 CEST (thirty minutes from now) or as events warrant.

Thank you for your patience.
Posted Jun 16, 2020 - 16:30 CEST
Update
Our team is continuing to investigate this issue.

Next update is at 16:30 CEST (thirty minutes from now) or as events warrant.
Posted Jun 16, 2020 - 16:00 CEST
Investigating
We’re sorry everyone, it seems some Planday accounts aren’t loading properly. Apologies for any problems this causes you — we are working hard to resolve it. We will let you know when it’s fixed. Thanks for your patience!
Posted Jun 16, 2020 - 15:33 CEST