Payroll / reporting data delayed for some accounts
Incident Report for Planday
Resolved
This incident has been resolved.
Posted 5 months ago. Mar 20, 2019 - 16:43 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 5 months ago. Mar 20, 2019 - 16:22 CET
Investigating
We are currently experiencing delays in payroll data for some Planday accounts.
Please bare with us whilst we investigate the issue.
Posted 5 months ago. Mar 20, 2019 - 15:57 CET