Slow response time for some Planday accounts
Incident Report for Planday
Resolved
We have applied multiple fixes and will monitor the situation going forward. This will be the last update on this issue.
Thanks for staying with us while we fighting this!
Posted Apr 20, 2018 - 01:22 CEST
Identified
We believe to have identified several issues and is now working on a fix. While most customer would have been able to use the system, some might have experienced slow performance.
We appreciate your patience while we look into this!
Posted Apr 19, 2018 - 23:21 CEST
Investigating
Some Planday accounts are experiencing some slow load times. We’re looking into what’s causing this. In the meantime, apologies for the trouble.
Posted Apr 19, 2018 - 22:15 CEST