Degraded performance for in the People section
Incident Report for Planday
Resolved
The incident is resolved, thank you for hanging in there.
Posted 3 months ago. Mar 04, 2019 - 15:54 CET
Investigating
We’re sorry to say that we are experiencing degraded performance in the People section.
Please bare with us whilst we investigate this issue.
Posted 3 months ago. Mar 04, 2019 - 15:27 CET
This incident affected: Planday Web.