Degraded performance for all accounts
Incident Report for Planday
Resolved
This incident has been resolved.
Posted 2 months ago. Apr 05, 2019 - 17:25 CEST
Update
We are continuing to work on a fix for this issue.
Posted 2 months ago. Apr 05, 2019 - 16:38 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted 2 months ago. Apr 05, 2019 - 15:39 CEST
Investigating
We’re very sorry to say that a large number of Planday accounts are experiencing degraded performance at the moment. Fixing this is our #1 priority right now. We greatly appreciate your patience.
Posted 2 months ago. Apr 05, 2019 - 15:10 CEST
This incident affected: Planday Web, Punch Clock and Mobile App (Mobile App - iOS, Mobile App - Android, Kiosk App).