Punch Clock unaivailable for some accounts
Incident Report for Planday
Resolved
This incident has been resolved.
Posted Mar 19, 2020 - 16:25 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 19, 2020 - 13:24 CET
Investigating
Punch Clock is experiencing some performance issues. We’re sorry for any disruption this causes. We will let you know once this is resolved. Thanks for your patience.
Posted Mar 19, 2020 - 13:13 CET
This incident affected: Punch Clock.