Punch Clock issues for some accounts
Incident Report for Planday
Resolved
This incident has been resolved.
Posted Feb 14, 2020 - 10:15 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 14, 2020 - 10:00 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 14, 2020 - 09:48 CET
Investigating
Punch Clock is experiencing some performance issues. We’re sorry for any disruption this causes. We will let you know once this is resolved. Thanks for your patience.
Posted Feb 14, 2020 - 09:27 CET
This incident affected: Punch Clock.