Slow response time for some Planday customers
Incident Report for Planday
Resolved
This incident has been resolved.
Posted Feb 19, 2021 - 21:45 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 19, 2021 - 13:30 CET
Identified
The issue has been identified and we are working on a resolution.
Posted Feb 19, 2021 - 11:51 CET
Investigating
Some Planday customers are experiencing slow loading times.
Our team is working to identify the root cause and implement a solution.
We will send an additional update as events warrant.
Posted Feb 19, 2021 - 11:25 CET