Payroll issues affecting all accounts
Incident Report for Planday
Resolved
This incident has been resolved.
We thank you for your patience while we investigated the issue.
Posted Jul 26, 2022 - 08:41 CEST
Investigating
We’re very sorry to report that a large number of Planday accounts are experiencing issues with running payroll right now.
Our team is working to identify the root cause and mitigate impact.
We will send an additional update in 30 minutes or as events warrant.
Posted Jul 26, 2022 - 08:09 CEST
This incident affected: Web.