Help Center may be inaccessible for some users

Incident Report for Planday

Resolved

This incident has been resolved.
Posted Jan 19, 2026 - 12:11 CET

Update

The Help Center is now fully accessible in all languages. Some pages may take slightly longer to load while we implement improvements. We’re continuing to work on a permanent fix.
Posted Jan 16, 2026 - 17:08 CET

Update

Our team is working closely with our Third-party provider to resolve this issue.

In the meantime, you can still access Help Center articles via the Planday Help chat or through the links below:
EN https://intercom-help.eu/planday/en
DK https://intercom-help.eu/planday/da
DE https://intercom-help.eu/planday/de
NO https://intercom-help.eu/planday/nb
SE https://intercom-help.eu/planday/sv
Posted Jan 16, 2026 - 10:54 CET

Update

We are continuing to work on a fix for this issue.
While help.planday.com may be unavailable at times, all Help Center articles remain accessible via Help chat in Planday.
Posted Jan 16, 2026 - 06:58 CET

Update

We are continuing to work on a fix for this issue.
We appologize for any inconvenience this may cause.
Posted Jan 15, 2026 - 15:16 CET

Identified

The issue has been identified. We'll update you as events warrant.
Posted Jan 15, 2026 - 12:55 CET

Update

Our service provider is still investigating the issue.
While help.planday.com may be unavailable at times, all Help Center articles remain accessible via Help chat in Planday.

Updates will be posted here as they become available.
Posted Jan 14, 2026 - 21:47 CET

Update

Our Third party provider is still investigating the issue.
We'll update you as events warrant.
Posted Jan 14, 2026 - 18:20 CET

Update

Our Third party provider is investigating the issue.
Posted Jan 14, 2026 - 17:27 CET

Update

We are continuing to investigate this issue.
Posted Jan 14, 2026 - 16:37 CET

Investigating

We have reports of some users being intermittently not able to access some pages in our Help Center.
We are investigating the issue and will update here as events warrant.
Posted Jan 14, 2026 - 16:36 CET
This incident affected: Web.