Third party incident impacting support phone lines
Incident Report for Planday
Resolved
This incident has now been resolved by our third party provider.
We apologize for the inconveniences this may have caused.
Posted Dec 20, 2023 - 20:42 CET
Identified
We're sorry to report that our technical support phone lines are unavailable due to a third-party incident.
In the meantime, our Support is available via the chat functionality located within your Planday portal.
This page will be updated as we get more information from our third-party provider.
Posted Dec 20, 2023 - 14:01 CET