Planday is running slowly for some accounts
Incident Report for Planday
Resolved
This incident has been resolved.
Posted Feb 19, 2020 - 11:00 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 19, 2020 - 10:34 CET
Investigating
We’re sorry to report that Planday is running a bit slowly for some accounts. We’re working on a fix for this and will update you as soon as we have a solution.
Posted Feb 19, 2020 - 10:20 CET
This incident affected: Web.