Web Service Disruption

Incident Report for Planday

Resolved

The issue affecting web access has been resolved. We apologize for any inconvenience.
Posted Jul 31, 2025 - 22:02 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 31, 2025 - 21:26 CEST

Investigating

We are currently experiencing a service disruption accessing portals via web browser.
Our team is working to identify the root cause and we will send an additional update in 30 minutes or as events warrant.
Posted Jul 31, 2025 - 21:08 CEST
This incident affected: Web.