Planday Help Center currently unavailable
Incident Report for Planday
Resolved
This incident has been resolved.
Posted Jul 28, 2020 - 10:29 CEST
Update
We continue to investigate this issue. In the meantime, you can follow this link https://intercom.help/planday/ to access the Planday Help Center.
Posted Jul 28, 2020 - 10:05 CEST
Investigating
We are currently investigating this issue.
Posted Jul 28, 2020 - 09:25 CEST