UK Technical Support phone line unavailable due to third-party issues
Incident Report for Planday
Resolved
We apologise to those of our UK customers who were unable to reach our support phone line for the duration of this incident, and thank you for your patience..
This incident has been resolved and our UK support team is now reachable by phone.
Posted Oct 20, 2020 - 16:50 CEST
Update
We're sorry to report that our UK technical support phone line is still unavailable due to a third-party incident currently being investigated.
In the meantime, our Support is available via the chat functionality located within your Planday portal, where you can also request a call-back by leaving your phone number in the chat window.
This page will be updated at 18:30 CEST or as events warrant.
Posted Oct 20, 2020 - 09:55 CEST
Update
The issue is still under investigation by the third-party provider and we sincerely apologise to those of our customers who have been unable to reach Planday's UK phone line.

We will update this page Tuesday, October 20th at 10:00 CEST.
Posted Oct 19, 2020 - 18:30 CEST
Update
We're sorry to report that our UK technical support phone line is still unavailable.
Our third-party provider is still investigating issues on their end and we will update here as soon as we receive additional information from our provider.
In the meantime, please use our chat functionality located within your Planday portal.
Posted Oct 19, 2020 - 09:30 CEST
Update
Our UK support team will be back on Monday.
We apologise to those of our customers who have been unable to reach our UK phone line.
We are in dialogue with our third-party provider to ensure they mitigate issues on their end.
This page will be updated Monday, October 19th at 09:30 CEST.
Posted Oct 16, 2020 - 18:30 CEST
Investigating
We are currently experiencing an issue with our UK Support phone line.
We are investigating the issue. In the meantime, please use our chat functionality located within your Planday portal.
Posted Oct 16, 2020 - 15:43 CEST