Issues with MFA

Incident Report for Planday

Resolved

This incident has been resolved. We apologize for any inconvenience this may have caused and appreciate your patience.
Posted Mar 02, 2026 - 11:28 CET

Monitoring

All messages affected have now been sent. We'll keep monitoring.
Posted Mar 02, 2026 - 11:12 CET

Update

We've identified the issue and implemented a fix. We're already seeing improvements now.
Posted Mar 02, 2026 - 11:06 CET

Investigating

Some users may experience issues with MFA (SMS not being received). We're currently investigating the issue and will update you as events warrant.
Posted Mar 02, 2026 - 10:14 CET
This incident affected: Web, Mobile App - iOS, and Mobile App - Android.