Issues with Plandays help centre
Incident Report for Planday
Resolved
This incident has been resolved.
Posted Oct 09, 2024 - 11:38 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 09, 2024 - 11:30 CEST
Investigating
Our help centre may not be accessible for some users on Web/Mobile.
We are currently investigating the issue.
Posted Oct 09, 2024 - 11:20 CEST
This incident affected: Web.