Problems loading schedule
Incident Report for Planday
Resolved
This incident has been resolved.
Posted Jun 29, 2020 - 12:36 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 29, 2020 - 12:07 CEST
Investigating
We are currently investigating this issue.
Posted Jun 29, 2020 - 11:57 CEST
This incident affected: Mobile App (Mobile App - iOS, Mobile App - Android) and Planday Web.