Some portals might experience error message "Stuck in Orbit"
Incident Report for Planday
Resolved
This incident has been resolved.
Posted 18 days ago. Sep 02, 2019 - 15:16 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted 18 days ago. Sep 02, 2019 - 15:15 CEST
Investigating
We are currently investigating this issue.
Posted 18 days ago. Sep 02, 2019 - 15:06 CEST
This incident affected: Mobile App (Mobile App - iOS, Mobile App - Android, Kiosk App) and Planday Web.