Slow response time for some Planday accounts
Incident Report for Planday
Resolved
This incident has been resolved.
Posted Nov 20, 2020 - 17:33 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 20, 2020 - 16:24 CET
Investigating
We're sorry to report that some users might experience longer response times or timeout errors in Planday.

Our team is working to identify the root cause and implement a solution.
Posted Nov 20, 2020 - 15:13 CET
This incident affected: Planday Web and Mobile App (Mobile App - iOS, Mobile App - Android, Kiosk App).