Problems loading some accounts
Incident Report for Planday
Resolved
All Planday accounts should be up and running again now. Thanks for being patient with us.
Posted Oct 30, 2019 - 15:39 CET
Investigating
We’re sorry everyone, it seems some Planday accounts aren’t loading properly. Apologies for any problems this causes you — we are working hard to resolve it. We will let you know when it’s fixed. Thanks for your patience!
Posted Oct 30, 2019 - 15:29 CET
This incident affected: Planday Web and API.