Help chat, email and help centre currently unavailable due to third-party incident

Incident Report for Planday

Resolved

This incident has been resolved.
Posted Nov 19, 2025 - 19:30 CET

Monitoring

Our service provider has implemented a fix and is currently monitoring performance.
We will update this page as the third party incident progresses.
Posted Nov 19, 2025 - 19:10 CET

Investigating

We're sorry to report that users are unable to access Planday's help chat, email and help centre due to incident at third-party provider.
We are currently awaiting third-party mitigation and will update this page as events warrant.
Posted Nov 19, 2025 - 17:47 CET
This incident affected: Help Chat.