Problems loading some accounts
Incident Report for Planday
Resolved
All Planday accounts should be up and running again now. Thanks for being patient with us. We hope the rest of your day goes well!
Posted Oct 14, 2019 - 13:32 CEST
Investigating
We’re sorry everyone, it seems some Planday accounts aren’t loading properly. Apologies for any problems this causes you — we are working hard to resolve it. We will let you know when it’s fixed. Thanks for your patience!
Posted Oct 14, 2019 - 13:24 CEST
This incident affected: Mobile App (Mobile App - iOS, Mobile App - Android, Kiosk App) and Planday Web, Punch Clock.