Incident caused by a 3rd party
Incident Report for Planday
Resolved
Our provider has mitigated the networking issue. Our systems are back online. Thank you so much for hanging in there.
Posted Oct 30, 2019 - 10:13 CET
Investigating
We right now experience issues due to an incident at one of our providers. Fixing this is our #1 priority right now. We greatly appreciate your patience.
Posted Oct 30, 2019 - 10:06 CET
This incident affected: Planday Web.