Planday is running slowly for some accounts
Incident Report for Planday
Resolved
Good news: it looks like we’re in the clear! All speed issues are now resolved. We appreciate your patience with us on this. Enjoy the rest of your day!
Posted Oct 17, 2019 - 15:29 CEST
Investigating
We’re sorry to report that Planday is running a bit slowly for some accounts. We’re working on a fix for this and will update you as soon as we have a solution.
Posted Oct 17, 2019 - 15:18 CEST
This incident affected: Mobile App (Mobile App - iOS, Mobile App - Android, Kiosk App) and Planday Web, Punch Clock, API.