Emails delayed due to third-party disruption

Incident Report for Planday

Resolved

This incident has been resolved.
Posted Jun 23, 2026 - 15:24 CEST

Identified

Users might experience delays in receiving emails due to issues on our service provider’s side.
Posted Jun 23, 2026 - 14:12 CEST
This incident affected: Web, Punch Clock, Mobile App - iOS, Mobile App - Android, Mobile Kiosk App, Open API, and Help Chat.