Periodic time out error with Payroll Reports
Incident Report for Planday
Resolved
This incident has been resolved.
Posted 14 days ago. Jun 03, 2019 - 12:41 CEST
Identified
Some admins receive a system error when generating a payroll report.
We are currently implementing a fix to mitigate the issue.
Posted 15 days ago. Jun 03, 2019 - 11:33 CEST