Degraded performance for some accounts
Incident Report for Planday
Resolved
We’re relieved to say we’re out of the woods! Planday accounts are up and running now. Thanks for bearing with us while we fixed this
Posted 3 months ago. Mar 21, 2019 - 15:05 CET
Investigating
We are experiencing degraded performance for some accounts.
Fixing this, is our highest priority. Thank you for hanging in there.
Posted 3 months ago. Mar 21, 2019 - 14:34 CET
This incident affected: Planday Web, Punch Clock and Mobile App (Mobile App - iOS, Mobile App - Android, Kiosk App).