Degraded performance for some Planday accounts
Incident Report for Planday
Resolved
We resolved the issue that was causing degraded performance. We're sorry for the disruption.
Posted 4 months ago. May 09, 2019 - 17:34 CEST
Update
We are continuing to monitor for any further issues.
Posted 4 months ago. May 09, 2019 - 17:00 CEST
Monitoring
We've fixed the issue and are monitoring closely to ensure there are no further disruptions. Thank you for your patience.
Posted 4 months ago. May 09, 2019 - 16:49 CEST
Investigating
We’re very sorry to say that a large number of Planday accounts are experiencing degraded performance at the moment. Fixing this is our #1 priority right now. We greatly appreciate your patience.
Posted 4 months ago. May 09, 2019 - 16:22 CEST
This incident affected: Planday Web and Punch Clock.