Issues accessing Planday portal via web in the North America region

Incident Report for Planday

Resolved

This incident has been resolved.
Posted Aug 24, 2022 - 18:45 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 24, 2022 - 18:28 CEST

Investigating

We are currently investigation reports of service disruptions affecting some customers in the North America region.

We will update this page as soon as we have more information
Posted Aug 24, 2022 - 18:26 CEST
This incident affected: Web.