Punch Clock issues for some accounts
Incident Report for Planday
Resolved
This incident has been resolved.
Posted Jul 21, 2020 - 09:45 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 21, 2020 - 09:20 CEST
Investigating
We’re sorry to report we are currently having an issue with Danish Planday accounts using Punch Clock. We’re doing everything we can to resolve this. Thanks for being patient with us, we will let you know when it’s fixed.
Posted Jul 21, 2020 - 09:00 CEST
This incident affected: Punch Clock.