Issues with creating employees are affecting some accounts
Incident Report for Planday
Resolved
This incident has been resolved.
Posted Dec 01, 2019 - 22:30 CET
Update
We are continuing to investigate this issue.
Posted Dec 01, 2019 - 22:00 CET
Investigating
We’re sorry to report that we are currently seeing issues when trying to create employees for some Planday accounts. We will get it fixed ASAP. Thanks for your patience with this. The next update will be in 30 mins.
Posted Dec 01, 2019 - 21:27 CET
This incident affected: Planday Web.