Slow response time for some Planday accounts
Incident Report for Planday
Resolved
We’re happy to report this issue is now fixed. Thanks for being patient with us while we solved it!
Posted Nov 05, 2019 - 16:08 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 05, 2019 - 14:14 CET
Update
We are continuing to investigate this issue.
Posted Nov 05, 2019 - 13:47 CET
Investigating
Some Planday accounts are experiencing slower loading times. Our apologies for any trouble this causes you. We will get it fixed ASAP and get back to you when it is.
Posted Nov 05, 2019 - 13:28 CET
This incident affected: Planday Web and Punch Clock.