Service Disruption
Incident Report for Planday
Resolved
This incident has been resolved.
Posted Feb 24, 2021 - 13:14 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 24, 2021 - 12:53 CET
Investigating
We are currently experiencing a service disruption.

Our team is working to identify the root cause and we will send an additional update in 30 minutes.
Posted Feb 24, 2021 - 12:45 CET
This incident affected: Web.